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NEW QUESTION 1
You use a workbook query to import a table named Customers that contains a column named CustomerName. CustomerName has names in the format of
Lastname, Firstname.
You need the CustomerName column to contain names in the format of Firstname Lastname. A space must separate Firstname and Lastname.
Which two commands should you use? To answer, drag the appropriate fields to the correct areas. Each field may be used once, more than once, or not at all.
You may need to drag the split bar between panes or scroll to view content.
NOTE: Each correct selection is worth one point.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 
 Split Column By Delimiter
 Merge Columns

https://support.office.com/en-us/article/split-a-column-of-text-power-query-5282d425-6dd 0-46ca-95bf-8e0da9539662
https://support.office.com/en-us/article/merge-columns-power-query-80ec9e1e-1eb6-4048-b500-d5d42d9f0

NEW QUESTION 2
Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the
stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
After you answer a question in this section, you will NOT be able to return to it. As a result, these questions will not appear in the review screen.
You have a query named Queryl that retrieves the user information from two Excel files. One of the Excel files does not contain location information. A sample of
the data retrieved by the query is shown in the following table.

You need to ensure that values in UserName are unique. The solution must ensure that the locations are retained. A sample of desired output is shown in the
following table.

Solution: You select the UserName and Location columns, and then you click Keep Duplicates. Does this meet the goal?

A. Yes
B. No

Answer: B

NEW QUESTION 3
You need to create a PivotChart as shown in the exhibit. (Click the Exhibit button.) Exhibit:
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Which field should you use for each area? To answer, drag the appropriate fields to the correct areas. Each field may be used once, more than once, or not at all.
You may need to drag the split bar between panes or scroll to view content.
NOTE: Each correct selection is worth one point.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 

Legend: BrandName Axis: MonthName

NEW QUESTION 4
You have a pie chart.
You need the wedges of the pie chart to be separated as shown in the following exhibit.

A. Change the chart type to Pie of Pie.
B. Right-click the pie chart, click Expand/Collapse, and then click Expand.
C. Right-click the pie chart, click Expand/Collapse, and Then click Expand Entire Field
D. Select a wedge of the pie chart and then drag the wedge.

Answer: D

NEW QUESTION 5
You have a workbook query that loads data from C:\Data\Users.xlsx. You move Users.xlsx to a shared folder on the network.
You need to ensure that you can refresh the data from Users.xlsx. What should you do?

A. From the Linked Table tab in Power Pivot, modify the Update Mode.
B. From Query Editor, modify the Source step.
C. From the Insert tab in Excel, click My Add-ins, and then manage the add-ins.
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D. From the Data tab in Excel click Connections, and then modify the properties of the connection.

Answer: D

NEW QUESTION 6
Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the
stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
After you answer a question in this section, you will NOT be able to return to it. As a result these questions will not appear in the review screen.
Your company has sales offices in several cities.
You create a table that represents the amount of sales in each city by month as shown in the exhibit.

You need to ensure that all values lower than 250 display a red icon. The solution must ensure that all values greater than 500 display a green icon.
Solution: You modify the conditional formatting rule, and then set a new value for the yellow icon. Does this meet the goal?

A. Yes
B. No

Answer: B

NEW QUESTION 7
Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the
stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
After you answer a question in this section, you will NOT be able to return to it. As a result, these questions will not appear in the review screen.
You have the following data.

You need to retrieve a list of the unique ProductName entries.
Solution: Open the Advanced Filter dialog box, select Filter the list, in-place, and then select Unique records only.
Does this meet the goal?

A. Yes
B. No

Answer: A

NEW QUESTION 8
You are building a KPI.
You need to configure the KPI to display a red icon when the sales from a month is less than nine percent of the sales from the last 12 months.
What should you use to define the target value?

A. an absolute value
B. a calculated column
C. a calculated field
D. a measure

Answer: A

Explanation: 
https://msdn.microsoft.com/en-us/library/hh272049(v=sql.110).aspx

NEW QUESTION 9
You have an Excel workbook query that loads data to a worksheet and the data model. You need to ensure that the data is refreshed whenever you open the
workbook.
What should you do?

A. From the File tab, click Option, and then modify the Data option.
B. From the File tab, click Options, and then modify the General options.
C. From the Data tab, click Queries & Connections, and then edit the properties of the query.
D. From the Power Pivot model, modify the Table Behavior setting.
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Answer: C

Explanation: 
https://support.office.com/en-us/article/refresh-an-external-data-connection-in-excel-2016-for-windows-152417

NEW QUESTION 10
Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the
stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
After you answer a question in this section, you will NOT be able to return to it As a result, these questions will not appear in the review screen.
You have an Excel workbook that contains a table named Table1. A sample of the data in Table1 is shown in the following table.

You need to create a PivotTable in PowerPivot as shown in the exhibit.

Solution: You create a hierarchy named Products that contains ProductCategory,
Solution: You create a measure named Products the uses the DataTable DAX Function. You add a PivotTable. You drag products to the Rows field. You drag
Price to the Values field.
Does this meet the goal?

A. Yes
B. No

Answer: B

NEW QUESTION 10
Note: This question is part of a series of questions that use the same scenario, For your convenience the scenario is repeated in each question. Each question
presents a different goal and answer choices, but the text of the scenario is the same in each question in this series.
Start of repeated scenario
You are creating reports for a car repair company. You have four datasets in Excel spreadsheets. Four workbook queries load the datasets to a data model. A
sample of the data is shown in the Data Sample exhibit.
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The data model is shown in the Data Model exhibit.

The tables in the model contain the following data:
DailyRepairs has a log of hours and revenue for each day, workshop, and repair type. Every day, a log entry is created for each workshop, even if no hours or
revenue are recorded for that day. Total Hours and Total Revenue are two measures defined in DailyRepairs. Total Hours sums the Hours column, and Total
Revenue sums the Revenue column.
Workshops has a list of all the workshops and the current and previous workshop managers. The format of the Workshop Manager column is always Firstname
Lastname. A value of 1 in the IsLatest column indicates that the workshop manager listed in the record is the current workshop manager.
RepairTypes has a list of alt the repair types. Dates has a list of dates from 2015 to 2018. End of repeated scenario.
You plan to analyze The average revenue per hour by combinations of day, repair type, and workshop name. You need to create a measure to support the
planned analysis.
Which DAX formula should you use? To answer, drag the appropriate values to the correct targets. Each value may be used once, more than once, or not at all.
You may need to drag the split bar between panes or scroll to view content.
NOTE: Each correct selection is worth one point.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 
DIVIDE ([Total Revenue ],[ Total Hours], BLANK())

NEW QUESTION 14
Note: This question is part of a series of questions that use the same scenario. For your convenience, the scenario is repeated in each question. Each question
presents a different goal and answer choices, but the text of the scenario is the same in each question in this series.
Start of repeated scenario.
You are creating reports for a car repair company. You have four datasets in Excel spreadsheets. Four workbook queries load the datasets to a data model. A
sample of the data is shown in the Data Sample exhibit. (Click the Exhibit button.)
Data Sample exhibit:
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The data model is shown in the Data Model exhibit. (Click the Exhibit button.)

The tables in the model contain the following data:
 DailyRepairs has a log of hours and revenue for each day, workshop, and repair type. Every day, a log entry is created for each workshop, even if no hours or

revenue are recorded for that day. Total Hours and Total Revenue column.
 Workshops have a list of all the workshops and the current and previous workshop managers. The

format of the Workshop Manager column is always Firstname Lastname. A value of 1 in the IsLatest column indicates that the workshop manager listed in the
record is the current workshop manager.

 RepairTypes has a list of all the repair types
 Dates has a list of dates from 2015 to 2018

End of repeated scenario.
You need to add a custom column to the workbook query for Workshops that contains the email address of the workshop manager. The format of the email
address is firstname.lastname@contoso.com.
How should you complete the query from Query Editor? To answer, select the appropriate options in the answer area.
NOTE: Each correct selection is worth one point.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 
Text.Replace([Workshop Manager]," ",".")&Contoso.com
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NEW QUESTION 16
Note: This question is part of a series of questions that use the same scenario. For your convenience, the scenario is repeated in each question. Each question
presents a different goal and answer choices, but the text of the scenario is the same in each question in this series.
Start of repeated scenario
You have six workbook queries that each extracts a table from a Microsoft Azure SQL database. The tables are loaded to the data model, but the data is not
loaded to any worksheets. The data model is shown in the Data Model exhibit.

Your company has 100 product subcategories and more than 10,000 products. End of repeated scenario.
You need to create a simplified view of the workbook for some users. The simplified view must only display data from FactSales, DimProduct, and DimDate.
What should you do in the data model?

A. Click Hide from Client Tolls for all the tables except FactSales, DimProduct, and DimDate.
B. Create a new perspective.
C. Modify the Table Behavior settings for FactSales, DimProduct, and DimDate.
D. Add the columns from FactSales, DimProduct, and DimDate to the Default Field Set.

Answer: A

NEW QUESTION 18
You have a model that contains data relating to corporate profits. The model contains a measure named Profit.
You need to create a PivotTable to display the Profit measure in three different formats by using the Show Value As feature. The PivotTable must produce the
results shown in the following table.
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How should you configure the Show Value As feature for % Profit of Annual Total and % profit of Grand Total? To answer, select the appropriate options in the
answer area.
NOTE: Each correct selection is worth one point.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 
% Profit of Annual Total: % of Parent Total
% Profit of Grand Total: % of Column Total
https://support.office.com/en-us/article/show-different-calculations-in-pivottable-value-f ields-014d2777-baaf-480b-a32b-98431f48bfec

NEW QUESTION 20
You need to create a combo chart to display the count of orders by month and profit by month as shown in the exhibit. (Click the Exhibit tab.)

How should you configure the combo chart? To answer, select the appropriate options in the answer area. NOTE: Each correct selection is worth one point.
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A. Mastered
B. Not Mastered

Answer: A

Explanation: 
Order Count:Stacked columnNo Profit:LineYes
http://www.excel-easy.com/examples/combination-chart.html

NEW QUESTION 24
You have the PivotTable shown in the following exhibit.
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You need to display only rows in the PivotTable in which the sum of LineTotal is greater than 100. What should you do?

A. From Row Label, configure a Label filter.
B. Add a slicer for LineTotal and select the values from the slicer.
C. From Row Label, configure a Value Filter.
D. Add LineTotal to the Filters area of PivotTable Field
E. Configure the Filters value.

Answer: B

NEW QUESTION 29
You have a workbook query that loads data from a table named Products. Products contains a column named IntemalPrice that has a Data Type of Decimal.
From Query Editor you create a custom column named ResellerPrice that uses a formula to multiply InternalPrice by 1.2, and then you remove the IntemalPrice
column.
What will occur when you load the data to a worksheet?

A. All the columns except InternalPrice will load to the worksheet The values in ResellerPrice will be correct.
B. An error message will appear and all the data will fail to load.
C. An error message will appear and all the columns except InternalPnce and ResellerPrice will load to the worksheet.
D. All the columns except InternalPrice will load to the workshee
E. The values in ResellerPrice will be null.

Answer: D

NEW QUESTION 32
You have a table that contains sales data.
You need to create a Pivot Table that will display the sales by country as shown in the following exhibit.

What should you use to display the icons?

A. a measure
B. conditional formatting
C. data validation
D. a KPI

Answer: B

NEW QUESTION 34
You have the data model shown in the exhibit.
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You need to create a hierarchy from DimProductSubcategory[ProduaSubcategoryName]andDimProduct[ProductName].
What should you do before you create the hierarchy?

A. Create a relationship between the table
B. To DimProductSubcategory, add a calculated column named ProductName that uses the
LOOKUPVALUE(DimProduct[ProductName],DimProduct[ProductKey],[ProductKey]) DAX formula.
C. To DimProduct, add a calculated column named ProductSubcategoryName that uses the LOOKUPVALUE(DimProductSubcategory
[ProductSubcategoryName],DimProductSubcategory[ProductCategoryKey],[ProductSubcategoryKey]) DAX formula.
D. Create a relationship between the table
E. To DimProduct, add a calculated column named ProductSubcategoryName that uses the RELATEDTABLE
(DimProductSubcategory[ProductSubcategoryName]) DAX formula.
F. To DimProduct, add a calculated column named ProductSubcategoryName that uses the VALUES(DimProductSubcategory[ProductSubcategoryName]) DAX
formula.

Answer: B

NEW QUESTION 37
Note: This question is part of a series of questions that use the same scenario, For your convenience is repeated in each question. Each question presents a
different goal and answer choices, but the text of the scenario is the same in each question in this series.
Start of repeated scenario
You are creating reports for a car repair company. You have four datasets in Excel spreadsheets. Four workbook queries load the datasets to a data model. A
sample of the data is shown in the Data Sample exhibit.

The data model is shown in the Data Model exhibit.

The tables in the model contain the following data:
DailyRepairs has a log of hours and revenue for each day, workshop, and repair type. Every day, a log entry is created for each workshop, even if no hours or
revenue are recorded for that day. Total Hours and Total Revenue are two measures defined in DailyRepairs. Total Hours sums the Hours column, and Total
Revenue sums the Revenue column.
Workshops has a list of all the workshops and the current and previous workshop managers. The format of the Workshop Manager column is always Firstname
Lastname, A value of 1 in the IsLatest column indicates that the workshop manager listed in the record is the current workshop manager.
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Repair types has a list of all the repair types. Dates has a list of all the repair types.
Dates has a list of dates from 2015to 2018. End of repeated scenario.
You need to create a PivotChart that displays the month, the hours of the month, and the hours of the previous month, as shown in the following exhibit.

Which DAX formula should you use for the Total Hours Last Month measure? To answer, drag the appropriate values to the correct targets. Each value may be
used once, more than once, or not at all. You may need to drag the split bar between panes or scroll to view content.
NOTE: Each correct selection is worth one point.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 
IF (ISBLANK([Total Hours]), BLANK(), CALCUATE [Total Hours], DATESADD (tblDates[Date]),
-1,MONTH)))

NEW QUESTION 41
Your company has sales offices in several cities.
You create a table that represents the amount of sales in each city by month as shown in the exhibit.

You need to ensure that all values lower than 250 display a red icon. The solution must ensure that all values greater than 500 display a green icon.
Solution: You create a measure, and then define a target value. Does this meet the goal?

A. Yes
B. No

Answer: B

NEW QUESTION 46
You have a table named Date that contains the following data.

You have a table named Sales that contains the following data.
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You plan to create a PivotCharts that will be sliced by MonthName. You need to create a relationship between Sales and Date.
Which columns should you use to create the relationship? To answer, select the appropriate options in the answer area.
NOTE: Each correct selection is worth one point.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 

DATE: DateKey SALES: OrderDate Refer below

https://www.archerpoint.com/blog/Posts/creating-date-table-power-bi

NEW QUESTION 47
You have a table named AnnualSales. A sample of the data in AnnualSales is shown in the following table.

You need to create a PivotTable as shown in the exhibit. (Click the Exhibit tab.)
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How should you configure the Rows are and the Columns area in PivotTable Fields? To answer, drag the appropriate fields to the correct areas. Each field may be
used once, more than once, or not at all. You may need to drag the split bar between panes or scroll to view content.
NOTE: Each correct selection is worth one point.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 

NEW QUESTION 49
Note: This question is part of a series of questions that use the same scenario. For your convenience, the scenario is repeated in each question. Each question
presents a different goal and answer chokes, but the text of the scenario is the same in each question in this series.
Start of repeated scenario
You are creating reports for a car repair company. You have four datasets in Excel spreadsheets. Four workbook queries load the datasets to a data model. A
sample of the data is shown in the Data Sample exhibit.
Data Sample exhibit:
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The data model is shown in the Data Model exhibit. (Click the Exhibit button.)

The tables in the model contain the following data:
 DailyRepairs has a log of hours and revenue for each day, workshop, and repair type. Every day, a log entry is created for each workshop, even if no hours or

revenue are recorded for that day. Total Hours and Total Revenue column.
 Workshops have a list of all the workshops and the current and previous workshop managers. The format of the Workshop Manager column is always

Firstname Lastname. A value of 1 in the IsLatest column indicates that the workshop manager listed in the record is the current workshop manager.
 RepairTypes has a list of all the repair types
 Dates has a list of dates from 2015 to 2018

End of repeated scenario.
When you attempt to create a relationship between DailyRepairs and Workshops, Power Pivot generates the following error message: “The relationship cannot be
created because each column contains duplicate values. Select at least one column that contains only unique values”.
You need to ensure that you can create a valid relationship between the tables. What should you do?

A. In the Power Pivot model, change the data type for Workshop[ID] to General
B. In the workbook query for Workshops, add an index column
C. In the Power Pivot model, change the Table Behavior setting for Workshops
D. In the workbook query for Workshops, filter [IsLatest] to equal 1

Answer: C

Explanation: 
References: https://msdn.microsoft.com/en-us/library/hh560544(v=sql.110).aspx

NEW QUESTION 51
You have 12 sales reports stored in a folder as CSV files. Each report represents one month of sales data for a year. The reports have the same structure.
You need to analyze the entire year of sales data.
Which three actions should you perform in sequence? To answer, move the appropriate actions from the list of actions to the answer area and arrange them in the
correct order.

A. Mastered
B. Not Mastered

Answer: A
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Explanation: 
Click From CSV, and then select the first file in the folder. Edit the query, and then click Append Queries.
From the Power Pivot tab, click Add to Data Model.

NEW QUESTION 52
You have a workbook query that loads data from a table in a Microsoft Azure SQL database. The table has a column named LineTotal. The following is a sample
of the data in LineTotal:
• 40
• 1
• 999
• 7658
• 883432
You need to ensure that when you load the data to the model, LineTotal is set as currency. What should you do from Query Editor?

A. Configure the Data Type
B. Round the column.
C. Split the column by characters.
D. Split the column by delimiter.

Answer: A

NEW QUESTION 55
You have the following table named SalesOrder Detail in a model.

You need to calculate the sum of SalesTotal for all the rows that have a quantity greater than 1.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 
CALCULATE(SUMX(‘SalesOrdersDetail’[SalesTotal]),‘SalesOrderDetail’[Quantity] > 1)

NEW QUESTION 56
You have a measure named SalesGrowth that calculates the percent of sales growth. The measure uses the following formula.
([Total Sales Current Year] - [Total Sales Last Year]) / [Total Sales Last Year]
Total Sales Current Year is a measure that calculates the sales from the current calendar year. Total Sales Last Year is a measure that calculates the sales from
the previous calendar year.
You need to create a KPI that displays a red icon when the sales growth is less than last year. What should you use to define the target value?

A. an absolute value of 0
B. the Total Sales Current Year measure
C. an absolute value of 100
D. the Total Sales Last Year measure

Answer: D

NEW QUESTION 61
You add two tables named Date and Invoices to a data model, Invoices contains a column named InvoiceDate that has a Data Type of Date, Date contains a
column named DateID that has a Data Type of which Number. DateID is in the format of YYYYMMDD.
You need to create a relationship between Date and Invoices. What should you do first?

A. Change the Data Type of InvoiceDate and DateID to Text.
B. Create a measure in Invoices that uses the Format DAX Function.
C. Change the Data Type of DateID to Date.
D. Create a calculated column in Invoices that uses the Format DAX function.
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Answer: C

Explanation: 
https://support.office.com/en-us/article/data-types-in-data-models-e2388f62-6122-4e2b-bcad-053e3da9ba90?ui= 

NEW QUESTION 66
Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the
stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
After you answer a question in this section, you will NOT be able to return to it. As a result, these questions will not appear in the review screen.
You have two Microsoft SQL Server database servers named Production1 and Test1. Production1 contains the same tables as Test1, but only a subset of the
data.
You add Test1 as a data source, and you select 10 tables. You configure several transformations. You need to connect the model to the tables in Production1. The
solution must maintain the existing
transformations.
Solution: From Query Editor, you configure the Data source settings. Does this meet the goal?

A. Yes
B. No

Answer: A

NEW QUESTION 71
You have a PivotChart template named Template1. You add a PivotChart to a worksheet.
You need to apply the template to the PivotChart. What should you do?

A. On the Design tab, click Change Chart Type.
B. On the Format tab, click Format Selection.
C. Right-click the chart and then click PivotChart Options.
D. Right-click the chart and then click Format Chart Area.

Answer: A

Explanation: 
 Click the chart
 On the Charts tab, under Change Chart Type, click Other, and then under Templates, click the chart template that you created.

https://stackoverflow.com/questions/17386777/how-to-apply-a-saved-chart-template-to-an-existing-chart

NEW QUESTION 73
You create an Excel workbook named SalesResults.xlsx. You create a workbook query that connects to a Microsoft SQL Server Database and loads data to the
data model. You create a PivotTable and PivotChart.
You plane to share SalesResults.slsx to several users outside of your organization.
You need to ensure that the users can see the PivotTable and the PivotChart when they open the file. The data in the model must be removed.
What should you do?

A. Modify the source of the query.
B. From Query Editor, open the Data Source Setting and delete the credentials.
C. Run the Document inspector.
D. Save the workbook as an Excel Binary Workbook (xlsx)

Answer: A

Explanation: 
References:
https://support.office.com/en-us/article/data-source-settings-power-query-9f24a631-f7eb-4729-88dd-6a4921380

NEW QUESTION 78
You have the Excel worksheet shown in the exhibit.
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You need to transform the data by using Query Editor. What should you do first?

A. From the Data tab, Click From Table/Range.
B. From the Insert tab, Click Store.
C. From the Data tab, Click Flash Fill.
D. From the Data tab, Click Consolidate.

Answer: A

Explanation: 
Excel uses a dedicated Query Editor to facilitate and display data transformations. When you select Data > Get Data, then select the data source, such as a
workbook, or a database, the Navigator window appears so you can select which table (or tables) you want to use in your query. When you select a table, a
preview of its data is shown in the right pane of the Navigator window.
https://support.office.com/en-us/article/getting-started-with-get-transform-in-excel-2016-a8310388-2a12-438c-9

NEW QUESTION 79
You have 20 workbook queries that load 20 CSV files to a local computer.
You plan to send the workbook and the 20 CSV files to several users. The users will store the files in various location.
You need to ensure that the users can change the path to the CSV files in the queries as quickly as possible. What should you do from Query Editor?

A. Merge all the querie
B. Edit the source of the first query.
C. Create a paramete
D. Modify the source of each query to use the parameter.
E. For each query, create a new query that uses a referenc
F. Modify the source of each new query.
G. Append all the querie
H. Edit the source of the first query.

Answer: B

Explanation: 
https://www.howtoexcel.org/power-query/how-to-parameterize-your-power-query/ 

NEW QUESTION 83
You have two queries named Client and Invoices. A sample of Client is shown in the following table.

A sample of Invoices is shown in the following table.

You need to create a new table that has the following information.
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Which join kind should you use?

A. Inner
B. Left Outer
C. Right Anti
D. Left Anti

Answer: B

Explanation: 
https://www.excelguru.ca/blog/2015/12/16/merge-tables-using-outer-joins-in-power-query/

NEW QUESTION 84
You have a query that retrieves customers and their locations. You have a sample of the data as shown in the following table.

Additional customers and locations are added frequently.
You need to transform the data as shown in the following table.

What should you do?

A. Select the Locations columns and then select Split Column by Delimite
B. Use a comma as the delimiter and split into rows.
C. Select the Locations columns and then select Split Column by Delimite
D. Use a comma as the delimiter and split into columns.
E. Select the Customer columns, and then click Unpivot Columns.
F. Select the Customer columns, and then click Unpivot Other Columns.

Answer: A

NEW QUESTION 85
You have a table named Sales that has three columns named Region, Country, and SalesAmount. You create a PivotTable as shown in the following exhibit.

You need to ensure that the PivotTable appears in three columns as shown in the following exhibit.
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What should you do?

A. On the Design tab, click Report Layout and then click Show in Compact Form.
B. Move Country from the Rows area to the Columns area.
C. Move Country from the Rows area to the Values area.
D. On the Design tab, click Report Layout and then click Show in Tabular Form.

Answer: D

NEW QUESTION 88
You have an Excel spreadsheet that contains a PivotChart. You install Microsoft Power BI Publisher for Excel.
You need to add a tile for the PivotChart to a Power BI dashboard. What should you do?

A. From the Power BI tab in Excel, click Pin.
B. From the File menu in Excel, click Publish.
C. From powerbi.com, upload the excel workbook.
D. From powerbi.com, click Get apps.

Answer: A

NEW QUESTION 92
You merge several CSV files by using Query Editor.
You need to remove all the leading whitespaces and all the non-printable characters from a column.
What should you do to achieve each task? To answer, drag the appropriate actions to the correct goals. Each action may be used once, more than once, or not at
all. You may need to drag the split bar between panes or scroll to view content.
NOTE: Each correct selection is worth one point.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 
Box 1: From the Extract menu, click Trim Box 2: From the Extract menu, click Clean

NEW QUESTION 93
You have a model that contains data relating to corporate profits. The model contains a measure named Profit.
You need to create a PivotTable to display the Profit measure in three different formats by using the Show Value As feature. The PivotTabte must produce the
results shown in the following table.

How should you configure the Show Value As feature for % Profit of Annual Total and % Profit of Grand Total? To answer, select the appropriate options in the
answer area.
NOTE: Each correct selection is worth one point.
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A. Mastered
B. Not Mastered

Answer: A

Explanation: 
% Profit of Annual Total: % of Parent Total
% Profit of Grand Total: % of Column Total
https://support.office.com/en-us/article/show-different-calculations-in-pivottable-value-fields-014d2777-ba

NEW QUESTION 95
Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the
stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
After you answer a question in this section, you will NOT be able to return to it. As a result these questions will not appear in the review screen.
You have the following data.

You need to retrieve a list of the unique ProductName entries.
Select the ProductName column, and then click Group on the Data tab. Does this meet the goal?

A. Yes
B. No

Answer: B

NEW QUESTION 96
Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the
stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
After you answer a question in this section, you will NOT be able to return to it. As a result, these questions will not appear in the review screen.
You have a Power Pivot model that contains the following tables.

There is a relationship between Products and ProductCategory.
You need to create a hierarchy in Products that contains ProductCategoryName and ProductName.
Solution: You create a measure that uses the ISCROSSFILTERED DAX function Does this meet the goal?

A. Yes
B. No

Answer: B

NEW QUESTION 97
You have a table named Sales that has three columns named OrderDate, OrderNumber, and SalesAmount. You need to create the PivotTable as shown in the
following table.
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What should you use?

A. KPIs
B. sparklines
C. conditional formatting
D. banded rows

Answer: A

NEW QUESTION 99
......
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